ERP – Recuperação de Crédito – Não é possível selecionar operador ou assessoria de cobrança: Nenhum registro disponível para consulta
Incidente
Na rotina de Recuperação de Crédito do módulo Gestão de Contas a Receber, ao tentar selecionar um operador ou assessoria para um título do contas a receber, é apresentada a mensagem: Nenhum registro disponível para consulta.

Causa
Este incidente ocorre, pois o sistema não está localizando os parâmetros necessários de operador ou assessoria para a fase sugerida da cobrança.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Verifique qual a fase de cobrança está sendo sugerida na tela NF320DTC - Finanças / Gestão de Contas a Receber / Recuperação de Crédito / Distribuição de Títulos (Distribuição de Títulos para Recuperação de Crédito);

2. Verifique se já existe algum relacionamento desta fase com operador ou assessoria. As consultas para operador e assessoria são feitas respectivamente nas telas:
2.1.NF320LOF - Finanças / Gestão de Contas a Receber / Recuperação de Crédito / Operadores / Relacionamento Operadores X Fases;
2.2. NF320LAF - Finanças / Gestão de Contas a Receber / Recuperação de Crédito / Assessorias / Relacionamento Assessoria x Fase Recuperação de Crédito;
3. Caso não exista relacionamento em nenhuma das telas, deve cadastrar o relacionamento:

4. Caso exista relacionamento, mas para a operação incorreta (exemplo: quero distribuir um título para operador e a fase está relacionada com assessoria de cobrança) é necessário excluir o relacionamento atual e efetuar novo relacionamento para a operação desejada.
Observação:
A fase só pode estar relacionada com operador ou com assessoria, os dois vínculos nunca podem existir. Caso a fase já tenha sido utilizada na distribuição de títulos em algum momento, não será possível fazer a alteração.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.