HCM - WAAPI/AUTENTICAÇÃO - Dificuldade de Autenticação SAML no Aplicativo Waapi para Usuários Android
Incidente
No módulo Waapi, alguns usuários Android encontram dificuldade em realizar a autenticação SAML e é apresentada a mensagem: Falha na autenticação SAML.
Causa
Esta mensagem é apresentada, pois o certificado SAML utilizado pelo cliente não é confiável para todos os navegadores, especialmente em dispositivos Android. Testes realizados indicam que o problema está relacionado à configuração do certificado SAML no servidor ADFS.
Solução
Para que a mensagem "Falha na autenticação SAML" não seja apresentada, realize os passos a seguir:
1. Valide o certificado digital via consulta de certificado SSLSHOPPER, consulte pelo domínio: XXXXXXX.COM.BR
2. Entre em contato com a equipe responsável pela infraestrutura do servidor ADFS. Solicite que eles avaliem e ajustem o certificado SAML utilizado, pois o problema está relacionado à configuração desse certificado no servidor ADFS;
3. Acompanhe os ajustes realizados pela equipe de infraestrutura e verifique se o problema de autenticação SAML para usuários Android no aplicativo Waapi foi resolvido.