ERP – Aplicação e Financiamento – Não é possível atualizar contrato: Data Base "XX/XX/XX" com resgate efetuado, não é possível atualizar Aplicação/Captação do contrato XX
Incidente
No módulo Gestão de Tesouraria, ao tentar atualizar um contrato de Aplicação via tela NF606ACT - Finanças / Gestão de Tesouraria / Aplicação e Financiamento / Atualização Cálculo do Contrato (Atualização Cálculo do Contrato da Aplicação e Financiamento) é apresentada a mensagem: Não é possível atualizar contrato: Data Base "XX/XX/XX" com resgate efetuado, não é possível atualizar Aplicação/Captação do contrato XX.
Causa
Esta mensagem é apresentada, pois não é permitido efetuar nova atualização no contrato com a mesma data que foi efetuado o resgate. Ao resgatar um valor, o sistema já faz as atualizações necessárias até esta data, por isso que o usuário não deve processar a atualização novamente.
Solução
Utilize uma data posterior ao resgate para atualizar o contrato, como por exemplo, a próxima data disponível sugerida pelo sistema via tela NF606ACT - Finanças / Gestão de Tesouraria / Aplicação e Financiamento / Atualização Cálculo do Contrato (Atualização Cálculo do Contrato da Aplicação e Financiamento)
Observação
Na primeira atualização após um resgate, a rotina calcula o contrato desde o início com o novo valor que sobrou do saldo, por isso é listado todo o período e não somente o mês 08/2025 conforme o exemplo acima.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.