ERP – Telas Diversas – Erro ao executar requisição HTTP (POST): [EldSocketError] Socket Error # 11001 Host not found
Incidente
Ao tentar acessar telas diversas independente do módulo, como:
F302CCR - Finanças / Gestão de Contas a Receber / Contas a Receber / Consultas / Títulos;
F502CCP - Finanças / Gestão de Contas a Pagar / Contas a Pagar / Consultas / Títulos;
F600CON - Finanças / Gestão de Tesouraria / Conciliação / Conciliação Bancária;
F603CON - Finanças / Gestão de Tesouraria / Conciliação / Consultas > Movimentos x Extratos Conciliados;
F645CTB_CCCT - Controladoria / Gestão de Contabilidade / Contabilidade / Integrações Contábeis (Integração Contábil);
É apresentada uma das seguintes mensagens:
Erro ao executar requisição HTTP (POST): [EldSocketError] Socket Error # 11001 Host not found;
Não foi possível autenticar na plataforma SeniorX após algumas tentativas. Motivo: As chaves da aplicação no arquivo de configuração podem estar inválidas ou foram alteradas na plataforma, ou o tenant e o domínio podem estar inválidos.
Causa
Este incidente ocorre, pois o ERP está tentando conectar com a plataforma devido a algumas rotinas do módulo de Finanças que integram com a plataforma Senior X, porém as configurações de integração estão corretas ou não existem.
Solução
Como este incidente estava ocorrendo inclusive em clientes que não utilizam nenhuma rotina integrada com a plataforma, foi liberada uma correção nas versões 5.10.3.116 e e 5.10.4.62, para que estas rotinas respeitem o parâmetro 'Acessar o XTended em modo offline' na Central de Configurações Senior(SeniorConfigCenter), resolvendo assim os problemas de conectividade.
Sendo assim, verifique internamente com seu T.I a viabilidade de atualizar a versão do ERP para uma das versões que contemplam a correção, caso esteja numa versão inferior a mencionado acima. Caso o ERP já esteja em uma versão igual ou posterior às mencionadas, é necessário verificar se na Central de Configurações Senior, o parâmetro 'Acessar o XTended em modo offline' está devidamente marcado, como neste exemplo:
Observação
Se a base utilizada é em ambiente cloud com a Senior, e necessita atualizar a versão e marcar a opção citada na Central de Configuração Senior, é necessário abrir um ticket para a equipe da It Services fazendo a solicitação.