HCM – S-1200 – [ERRO] null
Incidente
No módulo Administração de Pessoal, ao tentar gerar o evento S-1200 de um colaborador terceiro, o sistema não conclui o processamento e exibe a mensagem de erro: [ERRO] null.
Causa
Esse incidente ocorre porque o sistema não localiza um histórico de vínculo para o cadastro em questão, ou para outro cadastro que possua o mesmo CPF do colaborador que está sendo enviado.
Solução
Para evitar que o incidente ocorra ao tentar gerar o evento S-1200, siga os passos abaixo:
1. Acesse o módulo Administração de Pessoal;
2. Acesse o caminho Colaboradores / Históricos / Vínculo;
2.1. Informe o código do colaborador com erro, ou do cadastro com o mesmo CPF do colaborador;
2.2. Informe o vínculo do colaborador com a Data de Alteração igual à data de admissão.
3. Acesse eSocial / Eventos Periódicos / Envio Declaração Mensal e gere novamente o S-1200.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.