ERP Senior X – Notas Fiscais de Saída – 999 - Keyset does not exist
Incidente
No módulo Gestão de Faturamento do ERP Senior X, ao emitir a nota, é retornada a mensagem: 999 - Keyset does not exist.
Observação
Nos logs do eDocs a mensagem será:
Erro ao enviar lote de NF-e.
System.Security.Cryptography.CryptographicException: Keyset does not exist
at System.Security.Cryptography.Utils.CreateProvHandle(CspParameters parameters, Boolean randomKeyContainer)
at System.Security.Cryptography.Utils.GetKeyPairHelper(CspAlgorithmType keyType, CspParameters parameters, Boolean randomKeyContainer, Int32 dwKeySize, SafeProvHandle& safeProvHandle, SafeKeyHandle& safeKeyHandle)
at System.Security.Cryptography.RSACryptoServiceProvider.GetKeyPair()
at System.Security.Cryptography.RSACryptoServiceProvider..ctor(Int32 dwKeySize, CspParameters parameters, Boolean useDefaultKeySize)
at System.Security.Cryptography.X509Certificates.X509Certificate2.get_PrivateKey()
at Senior.SapiensNfe.Processos.Service.Documento.Autenticidade.AssinaturaDigital.Assinar(X509Certificate2 certificate, XmlDocument documento, String tagName, String nameSpace)
at Senior.SapiensNfe.Processos.Service.Nfe.Emissao.Envio.SerializadorEnvioNfe.Serializar(DadosLote lote, Filial filial, TipoEnvio tipoEnvio)
at Senior.SapiensNfe.Processos.Service.Nfe.Emissao.Envio.EnvioNfeSefazNormal.Enviar(IMensagemBroker apiBroker, DadosLote lote, TipoEnvio tipoEnvio, IControleContingencia controle, ISession sessao)
at Senior.SapiensNfe.Processos.Service.Nfe.Emissao.EmissaoNfe.Enviar(IMensagemBroker apiBroker, IList1 notas, IControleContingencia controle, ISession sessao, TipoEnvio tipoEnvio, Nullable1 estado)
Causa
Esta mensagem é retornada, pelos seguintes motivos:
- Problema na instalação do certificado digital;
- Problemas no ambiente onde o eDocs está instalado;
- Problemas na SEFAZ/Prefeitura/Autarquia para onde o documento está sendo enviado.
Solução
Para que a mensagem não seja retornada ao efetuar a emissão da nota, realize os passos a seguir:
1. Acesse o eDocs;
1.1. Acesse o menu Configurações / Certificados;
1.2. Selecione o certificado da empresa/filial onde a nota foi emitida;
1.3. Clique no botão Alterar:
1.4. Clique no botão Detalhes do certificado:
1.5. Verifique se a Chave privada está como Sim, se estiver como Não será necessário exportar o certificado com a chave privada e configurar ele novamente no eDocs:
Observação
- Para maiores informações sobre como exportar o certificado com a chave privada, verifique o artigo: eDocs - Certificado Digital - Erros ao importar o certificado digital.
- Se já emitiu notas com este certificado, só reiniciando o tenant ou os serviços do eDocs a situação já será resolvida, desde que a chave privada esteja como Sim no eDocs. Neste caso solicite apoio ao suporte da Senior.
2. Acesse o menu Mercado / Gestão de Faturamento / Notas Fiscais de Saída;
2.1. Selecione a nota que apresentou a rejeição;
2.2. Clique no botão Editar;
2.3. Acesse a guia Resumo;
2.4. Reprocesse o evento com falha e a nota será autorizada.