HCM - Gestão do Ponto - Monitoramento do banco acusando centenas de milhares de login/logoffs oriundos dos servidores do glassfish
Incidente
No monitoramento do banco de dados foi percebido que existem centenas de milhares de login/logoffs oriundos dos servidores do glassfish do Gestão do Ponto a cada hora, gerando lentidão e travamento no sistema.
Causa
Este incidente pode ocorrer por configurações feitas que não seguiram a documentação no Glassfish do Gestão do Ponto.
Solução
Para que este incidente não ocorra, realize os passos a seguir:
1. No painel de administração do Glassfish do gestão do ponto, acesse "Recursos / JDBC / JDBC Connection Pools" e verifique a conexão JDBC criada para o Gestão do Ponto, só pode existir uma e com o nome "gestaoponto-dataccess", conforme consta na documentação da instalação da nova interface do Gestão do Ponto;
2. Ainda na configuração do gestaoponto-dataccess, selecione-a, e verifique se a configuração está de acordo com o que está descrito na documentação Instalação da nova interface do Gestão do Ponto;
2.1 Se o banco for Oracle, o campo driverClassName precisa ter o valor "oracle.jdbc.OracleDriver";
2.2 Se o banco for SQL Server, o campo driverClassName precisa ter o valor "com.microsoft.sqlserver.jdbc.SQLServerDriver";
2.3 Se o banco for PostgreSQL, o campo driverClassName precisa ter o valor "org.postgresql.Driver";
3. No diretório de instalação do Glassfish do Gestão do Ponto (de todos os domínios, caso haja mais de um), apagar o conteúdo da pasta "\glassfigh\glassfigh\domain\osgi-cache\felix".
Observação:
Caso seja necessário realizar algum desses procedimentos acima, será necessário reiniciar o domínio.