ERP – Pagamento Eletrônico – Não é possível gerar remessa: Título: Filial XX, Número XX, Tipo XX e Fornecedor XX não possui código de barras informado. Deve ser informado o código de barras para os tipos de pagamento configurados para utilizarem código de
Incidente
No módulo Gestão do Contas a Pagar, ao tentar gerar uma remessa do pagamento eletrônico, é retornada a mensagem: Título: Filial XX, Número XX, Tipo XX e Fornecedor XX não possui código de barras informado. Deve ser informado o código de barras para os tipos de pagamento configurados para utilizarem código de barras.
Causa
Esta mensagem é retornada, pois o tipo de pagamento na grid está configurado para utilizar código de barras, porém o título não possui código de barras informado.
Solução
1. Para que este incidente não ocorra, realize os passos a seguir;
1.1. Verifique qual o tipo de pagamento consta na grid, para o título retornado na mensagem;
1.2. Acesse a tela NF030PPE - Cadastros / Finanças / Bancos / Parâmetros / Pagamento Eletrônico (C.Pagar - Parâmetros Pagamento Eletrônico) e verifique como está parametrizado no portador, este tipo de pagamento no campo Tipo pgto utiliza código de barras;
1.3. Caso este tipo de pagamento de fato deva utilizar código de barras, é necessário manter o parâmetro acima = S e informar um código de barras no título, dessa forma a mensagem não será mais retornada em tela;
Observação
- Caso a opção Sugerir Tipos de Pgto esteja selecionada no botão Seleção da tela F510PRM, o próprio sistema deve validar que não existe código de barras no título, e sugerir a opção mais adequada.
- Caso esta opção já esteja selecionada e mesmo assim o problema ocorre, verifique o artigo a seguir: ERP – Pagamento Eletrônico – Tipo de pagamento sendo sugerido incorretamente na tela de remessa do pagamento eletrônico