HCM - Gestão do Ponto - Não foi possível efetuar a autenticação
Incidente
No módulo Gestão do Ponto, ao tentar autenticar ocorre a mensagem: Não foi possível efetuar a autenticação. Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.6.2.v20151217-774c696): org.eclipse.persistence.exceptions.DatabaseException Internal Exception: java.sql.SQLRecoverableException: Closed Connection Error Code: 17008 Call: SELECT criUsu, CodUsu, TipCol, NumCad, NumEmp FROM r034usu WHERE (CodUsu = X) Query: ReadAllQuery(name="UsuarioColaborador.findByCodigoUsuario" referenceClass-UsuarioColaborador sql="SELECT criUsu, CodUsu, TipCol, NumCad, NumEmp FROM r034usu WHERE (CodUsu = ?)").
Causa
Esta mensagem é apresentada, pois a conexão com o banco de dados foi fechada durante a tentativa de autenticação no módulo Gestão do Ponto e não foi reestabelecida.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse o painel de administração do Glassfish;
2. Navegue até o menu "Resources / JDBC / JDBC Resources";
3. Selecione a conexão JDBC referente ao Gestão do Ponto, normalmente com o nome "gestaoponto-dataaccess";
4. Clique na aba "Advanced";
5. Marque a opção "Connection Validation";
6. No campo "Table Name", insira a tabela "R999VER";
7. Reinicie o serviço do Glassfish.
Observação:
Caso exista mais de um domínio do Glassfish para o Gestão do Ponto, essa configuração deve ser feita em todos eles.