ERP - Consulta de Lançamentos Contábeis - Não é possível inserir registro com chave duplicada
Incidente
No módulo Gestão de Contabilidade, ao tentar consultar os lançamentos contábeis, é apresentada a mensagem: Não é possível inserir registro com chave duplicada.
Causa
Este incidente ocorre, pois existem inconsistências na Configuração dos Campos da Grid fazendo com que a consulta de lançamentos retornem lançamentos duplicados.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse a tela F650CLC - Controladoria / Gestão de Contabilidade / Contabilidade / Consultas / Lançamentos / Contábil (Consulta de Lançamentos Contábeis) e consulte um ou mais movimentos. Em seguida, clique no "C" azul localizado no canto superior esquerdo da Grid, marque a opção Individual e clique no botão Restaurar original:
2. Ao aparecer a mensagem de Advertência, clique no botão Sim. Feche a tela de consulta de lançamentos e abra-a novamente. Consulte os lançamentos e a mensagem não será mais apresentada.