ERP MEGA - Portal de Vendas - Referência de objeto não definida para uma instância de um objeto
Incidente
No Portal de Vendas, ao testar o envio de e-mail através do Servidor SMTP é apresentada a mensagem: Referência de objeto não definida para uma instância de um objeto.
Causa
Esta mensagem é apresentada, pois na configuração do servidor SMTP está faltando informar a senha da conta e marcar o parâmetro 'Utiliza SSL/Criptografia'
Solução
Para que a mensagem não seja mais apresentada ao testar o envio de e-mail através do Servidor SMTP, realize os passos a seguir:
1. Acesse o Portal de Vendas com usuário Administrador;
2. Na aba Administração, clique no botão Parâmetros / Configurações do Sistema;
3. Na aba Configurações / Configurações Servidor SMTP, no campo Senha insira a senha da conta já configurada no campo Conta;
4. Ainda na aba Configurações / Configurações Servidor SMTP, marque o parâmetro 'Utiliza SSL/Criptografia';
5. Clique no botão Testar envio de e-mail;
6. Informe o e-mail para teste no campo Destinatário do e-mail de teste;
7. Clique no botão Enviar;
8. Será apresentada a mensagem: Email enviado com sucesso.
Observação: Você deverá verificar internamente com o setor de TI da empresa se os dados configurados no Servidor SMTP estão corretos.