ERP MEGA - Web Minutas - Caracteres especiais aparecendo como interrogação
Incidente
No Vimob Web, ao gerar uma Minuta pelo Web Minutas, os caracteres especiais são substituídos por pontos de interrogação.
Causa
Este incidente ocorre, pois faltam Dlls do Crystal e as chaves do Oracle em português.
Solução
Para que a minuta seja gerada corretamente, realize os passos a seguir no Servidor de Portais:
1. No Servidor de Portais, realize o passo 4 do artigo a seguir:
Como instalar o Client de Crystal 8.5
2. Clique em Iniciar / Executar e digite o comando regedit.exe;
3. Encontre a chave ORACLE;
3.1 Caso o servidor seja 32 bits, a chave encontra-se em HKEY_LOCAL_MACHINE / SOFTWARE / ORACLE;
3.2 Caso o servidor seja 64 bits, a chave encontra-se em WOW6432Node / SOFTWARE / ORACLE;
4. Na pasta do Client Oracle / Oracle Client, encontre o registro NLS_LANG:
4.1. Caso não encontre a chave, clique com o botão direito e selecione a opção Novo / Valor de Cadeia de Caracteres:
4.2. Insira o Nome NLS_LANG e clique em OK;
5. Dê dois cliques em cima da chave e altere o valor para BRAZILIAN PORTUGUESE_BRAZIL.WE8MSWIN1252;
6. Ainda na pasta do Client Oracle / OracleClient, encontre o registro NLS_DATE_FORMAT:
6.1. Caso não encontre a chave, realize o passo do item 3.1 ;
6.2. Insira o nome NLS_DATE_FORMAT e clique em OK;
7. Dê dois cliques em cima da chave e altere o valor para DD/MM/YYYY.
Observação: Antes de realizar qualquer alteração no Editor do Registro do computador, verifique com o responsável pela TI de sua empresa os impactos.
Atenção! Caso não possua as Dlls, segue o arquivo para download ao final deste artigo.