ERP MEGA - Impressão de relatórios - Invalid TLV record
Incidente
Ao tentar executar qualquer relatório, é apresentada a mensagem: Invalid TLV record.
Causa
Esta mensagem é apresentada, pois o formato que está sendo emitido está indo de encontro com as chaves de execução do Crystal no registro do Windows (regedit), que são criadas durante as configurações das máquinas para emissão de relatórios, ou seja, após a instalação dos clients do Crystal Reports.
Solução
Para que a mensagem não seja apresentada, primeiramente, verifique o espaço livre em disco nos seus servidores. É possível que esteja com falta de espaço para a realização deste processo.
Após isso, verifique se a pasta Formatos possui as permissões para todos os usuários na execução desse relatório. Para isso clique com o botão direito em cima da pasta Formatos / Propriedades / Compartilhamento / Compartilhar com todos os usuários e dê permissão de Leitura e Gravação.
Se caso não resolver, desinstale todas as versões do Crystal e instale na seguinte sequência: primeiro instale a versão 8.5 e depois a versão XI. Para este processo, verifique os artigos: Como instalar o Client de Crystal 8.5 e Como instalar o Client de Crystal XI.