ERP MEGA - MegaConnectionManager - The service did not respond to the start or control request in a timely fashion
Incidente
Ao tentar iniciar o serviço do windows do MegaConnectionManager.exe, é apresentada a mensagem: Error 1053: The service did not respond to the start or control request in a timely fashion.
Causa
Esta mensagem é apresentada, pois o MegaConfig.xml está configurado de forma diferente da forma com que o serviço do Windows foi criado.
Solução
Para que a mensagem não seja mais apresentada e o MegaConnectionManager.exe seja executado normalmente, realize os passos a seguir:
1. No Servidor de Aplicação, acesse o diretório raiz do Mega e abra a pasta Config;
2. Clique com o botão direito em cima do arquivo MegaConfig.xml e selecione a opção Editar;
3. Localize a tag , nela verifique se está informado corretamente a Connect String do banco de dados:
Observação: Caso não tenha certeza do nome da Connect String consulte o artigo Como localizar o arquivo TNSNAMES.ORA.
4. Verifique a tag se está igual ao que foi criado no serviço do Windows, para isso realize os passos a seguir:
4.1 Clique em Iniciar e digite o comando Services.msc:
4.2 Localize o serviço do MegaConnectionManager.exe e verifique o nome do serviço, quando o mesmo é criado, o nome é Mega Empresarial Connection Manager(ORCL/8099/8399). No caso da imagem abaixo a porta que deve estar informada no MegaConfig.xml é a 8299:
5. Após essas configurações checadas, salve e feche o arquivo e inicie o serviço do MegaConnectionManager.exe normalmente.
Observação: Como referência consulte o artigo Como reiniciar o MegaConnectionManager.exe.