ERP MEGA - Mega ERP - ORA-12514: TNS: listener não tem conhecimento sobre o serviço solicitado atualmente no descritor de conexão. A aplicação será finalizada
Incidente
Ao tentar realizar o login no Mega ERP, é apresentada a mensagem: Os dados da linha do sistema não puderam ser carregados. Mensagem do servidor: ORA-12514: TNS: listener não tem conhecimento sobre o serviço solicitado atualmente no descritor de conexão. A aplicação será finalizada.
Causa
Esta mensagem é apresentada, pois o serviço da instância da base Oracle utilizada pelo Mega não está iniciada impossibilitando a utilização do MegaERP.
Solução
Para que a mensagem não seja apresentada ao acessar o Mega e caso o servidor de Aplicação e de Banco de Dados sejam distintos, realize os passos a seguir:
1. No servidor de Aplicação, acesse o PL/SQL com o owner MEGA e informe a senha;
Observação: Caso não tenha a senha entre em contato com o suporte ou o DBA responsável pela manutenção da base para que o mesmo disponibilize a senha.
2. Caso o banco de dados conecte normalmente, reinicie o MegaConnectionManager no servidor de aplicação, verifique artigo: Como reiniciar o MegaConnectionManager.exe.
3. Se ao acessar o banco de dados for apresentada a mesma mensagem, entre em contato com o DBA (Administrador de Banco de Dados) responsável pela base, para que realize a análise do ambiente.
Caso o servidor de Aplicação e de Banco de Dados sejam o mesmo, realize os passos a seguir:
1. No servidor de Aplicação, clique no Iniciar do Windows e abra o Executar;
2. Digite o comando services.msc e clique em OK;
3. Localize o serviço do Oracle referente à instância usada para a base Mega, por padrão o nome do serviço é OracleServiceNomeInstancia;
4.Selecione o serviço, clique com o botão direito e aperte Iniciar;
5. Para validar se a base Oracle foi iniciada, acesse o PL/SQL com o owner Mega e informe a senha;
Observação: Caso não tenha a senha entre em contato com o suporte ou o DBA responsável pela manutenção da base para que o mesmo disponibilize a senha.
6. Caso o banco de dados conecte normalmente, reinicie o MegaConnectionManager no servidor de aplicação, verifique artigo: Como reiniciar o MegaConnectionManager.exe.
Observação: Caso o incidente persista mesmo após as alterações realizadas entre em contato com o DBA responsável pela manutenção da Base de Dados.