ERP MEGA - Server Crystal Exec parou de funcionar
Incidente
No Servidor de Relatórios, ao gerar qualquer relatório é apresentada a mensagem: Server Crystal Exec Parou de funcionar.
Ao expandir os detalhes é apresentado o log:
Nome do Evento de Problema: BEX.
Nome do Aplicativo: SrvMegaCrystalExec.exe.
Causa
Esta mensagem é apresentada, pois não foi configurado a opção de máxima conexão de portas TCP no servidor de relatórios e aplicação.
Solução
Para que esta mensagem não seja apresentada e os relatórios emitidos normalmente, realize os passos a seguir:
1. Nos Servidores de Aplicação e Relatórios, clique no Iniciar do Windows e abra o Executar;
2. Digite regedit.exe;
3. Ao abrir o Regedit cadastre as chaves no caminho
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters, com os valores:
Nome: MaxUserPort
Tipo: REG_DWORD
Dados: 65534 (decimal)
Nome: TcpTimedWaitDelay
Tipo: REG_DWORD
Dados: 60 (decimal)
4. Reinicie os Servidores após a alteração e a emissão dos relatórios funcionará com sucesso.
Atenção: Caso tenha dúvidas solicite a configuração ao responsável pelo TI da empresa.