ERP MEGA - MegaConnectionManager - The operation could not be completed. The service did not respond to the start or control request in a timely fashion
Incidente
Ao tentar acessar o MegaERP, é apresentada a mensagem: The operation could not be completed. The service did not respond to the start or control request in a timely fashion
Causa
A mensagem é apresentada, pois a imagem do executável MegaConnectionManager foi corrompida devido a um problema de conectividade no acesso UNC (compartilhamento da rede) ou erro na validação do DNS do servidor/rede.
Solução
Para que essa mensagem não ocorra ao tentar acessar o MegaERP, realize os passos a seguir:
1. Abra o iniciar do Windows e clique no botão Executar;
2. Digite o comando Services.msc e clique em OK;
3. Localize o serviço chamado Mega Connection Manager (BASE/PORTAA/PORTAB);
4. Clique com o botão direito e selecione Propriedades;
5. Na aba Geral, copie o Nome do serviço. Exemplo: MegaConnectionManager_BASE_PORTAA;
6. Abra novamente o menu iniciar do Windows e clique com o botão direito no Prompt de Comando;
7. Selecione a opção Executar como administrador;
8. Execute o comando a seguir para desinstalar o MegaConnectionManager como serviço do Windows: sc delete MegaConnectionManager_BASE_PORTAA
Exemplo:
9. Instale novamente o MegaConnectionManager como serviço do Windows, conforme artigo:
Como configurar o Megaconnectionmanager.exe como um serviço do Windows
10. Entre novamente no Services.msc (passos 1 e 2);
11. Localize o serviço MegaConnectionManager e clique com o botão direito;
12. Selecione a opção Propriedades;
13. Na aba Logon, opção Esta conta, insira a conta de usuário do Windows e senha no qual deseja configurar, conforme artigo:
Como alterar ou vincular uma conta de usuário Windows ao serviço do MegaConnectionManager.exe
14. Clique em OK para gravar as alterações;
Atenção! Clientes de ambiente Cloud não tem acesso a este procedimento e devem entrar em contato com a administradora do ambiente.