ERP MEGA - NFe - Rejeição NFe - CNPJ é inválido de acordo com seu tipo de dados
Incidente
No módulo NF-e, ao gerar lote de uma NF-e, é apresentada a mensagem de rejeição: CNPJ é inválido de acordo com seu tipo de dados.
Causa
Esta rejeição é apresentada, pois no cadastro do agente da nota fiscal o campo CNPJ está inválido.
Solução
Para que esta rejeição não seja apresentada ao gerar o lote de uma NF-e, realize os passos a seguir:
1. No Menu, clique em Todos os Módulos / Fiscal / NF-e / Movimentações / Ações NF-e;
2. Filtre pela NF-e rejeitada em questão;
3. Selecione a linha com a rejeição, clique em Visualizar e selecione a opção 'Visualizar XML Saída';
4. Pressione a combinação das teclas CTRL+F e na tela de busca, digite </enderEmit>;
5. Verifique se a tag está vazia referente as informações do cliente e da transportadora;
6. No Menu, clique em Empresarial / Global / Cadastros / Agentes, localize o agente da nota fiscal em questão e clique em Editar;
7. Na aba Geral, no campo CNPJ informe um CNPJ válido;
8. Clique em Confirmar;
9. No módulo NF-e, gere um novo xml de envio do lote.
Para mais informações sobre como gerar um novo XML de envio de lote, verifique o artigo: ERP MEGA - Nota Fiscal Eletrônica - Como gerar um novo XML de envio de lote