ERP MEGA - Emissão de relatórios - Relatório não encontrado
Incidente
No Mega ERP, ao tentar gerar qualquer relatório, é apresentada a mensagem: Relatório não encontrado: \\IP_SERVIDOR\MEGA\FORMATOS\TEMP\CONTAB\TempXXX\Nome_formato_relatorio.rpt.
Causa
Esta mensagem é apresentada, pois o usuário que está executando o relatório não tem permissão de acesso à pasta TEMP.
Solução
Para que o relatório seja emitido corretamente para o usuário, realize os passos a seguir no servidor de aplicação / relatórios:
Atenção! Antes de efetuar qualquer alteração, verifique com o responsável pela TI.
1. Localize a pasta TEMP, que fica no diretório raiz do Mega;
Observação: Caso tenha dúvidas em como localizar a pasta TEMP consulte o artigo Como localizar a pasta Formatos do Mega.
2. Clique com o botão direito do mouse na pasta Temp e selecione Propriedades:
3. Clique na aba Segurança e clique no botão Editar:
4. Clique no botão Adicionar:
5. Informe o usuário ou grupo de usuários que deseja conceder permissão e clique em OK:
6. Selecione o usuário ou grupo de usuários que foi incluído no passo 5, marque a opção Controle total conforme imagem abaixo e clique em OK:
7. Clique em OK e execute novamente o relatório.
Observação: Em alguns casos será necessário configurar as portas internas que o sistema operacional libera para as aplicações em geral, para isso consulte o artigo Como configurar a quantidade máxima de portas TCP utilizadas no Servidor Mega, caso tenha dúvidas em qual situação configurar as portas do Windows entre em contato com Suporte Mega.