ERP MEGA - MegaERP - ORA-12537 TNS Conexão Fechada
Incidente
No MegaERP, em qualquer processo é apresentada a mensagem: ORA-12537: TNS: Conexão Fechada.
Causa
Esta mensagem é apresentada, pois a configuração de autenticação do Oracle está como NTS e o endereço da connect está com o nome do servidor de banco de dados.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Nos Servidores de Aplicação, Relatórios e Integração do Mega, realize as configurações do SQLNET.ORA, para isso, verifique o artigo:
Como configurar o sqlnet.ora para o funcionamento correto do Mega.
2. Encontre e abra o TNSNAMES.ORA, para isso, verifique o artigo:
Como localizar o arquivo tnsnames.ORA.
3. No TNSNAMES encontre a connect do Mega;
4. Verifique no campo Host o nome do servidor de banco de dados e altere para o IP do servidor, como por exemplo:
NOME_CONNECT =
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS = (PROTOCOL = TCP)(HOST = IP_SERVIDOR )(PORT = 1521))
)
(CONNECT_DATA =
(SERVICE_NAME = NOME_BASE)
)
)
5. Reinicie o MegaConnectionManager em todos os servidores, para isso, verifique o artigo:
Como reiniciar o MegaConnectionManager.exe.
Observação: Solicite ao TI ou DBA, responsável pela manutenção do banco de dados, realizar o procedimento informado.
Atenção: Caso o incidente persista após as configurações, entre em contato com o DBA para que o mesmo verifique a conexão Servidor de Aplicação x Servidor de Banco de dados.