ERP MEGA - Relatórios - MegaERP.exe parou de funcionar
Incidente
No MegaERP, ao exportar qualquer relatório para Excel ou PDF, é apresentada a mensagem: MegaERP.exe parou de funcionar.
Causa
Esse incidente ocorre, pois as CRUFLs do Mega e DLLs do Client Crystal estão desatualizadas.
Solução
Para que o relatório seja exportado normalmente, realize os passos a seguir:
1. Clique com o botão direito em cima do atalho do Mega que está provavelmente na área de trabalho;
2. Clique em Propriedades e clique Abrir Local do Arquivo:
3. Volte à pasta anterior e encontre a pasta CRUFL;
4. Registre as CRUFLs em todas as estações que utilizam o Mega e também no servidor de aplicação, para isso, realize os passos do artigo:
Como registrar DLLs do Mega Empresarial em Sistemas Operacionais Windows;
5. No Iniciar do Windows, dentro do campo de pesquisa digite Run ou Executar;
6. Clique em OK;
7. Digite o comando REGEDIT.EXE e clique em OK:
8. Ao abrir o Editor de Registros, clique em computador e aperte o comando CTRL+F no teclado;
9. Em localizar, digite CRUFLMgFro e clique em Localizar Próxima:
10. Delete a CRUFLMgFro que aparecer e aperte F3 para localizar outros registros;
Atenção: Caso não encontre nenhum registro da CRUFLMgFro execute o item 12.
11. Delete todas e clique em OK;
Atenção: Somente exclua a CRUFLMgFro caso não utilize o módulo Frota .
12. Realize o processo do artigo: Configuração de Servidor ou Estação para emissão de relatórios;
13. Após configurações os relatórios serão exportados normalmente.
Observação: As CRUFLs estão disponíveis no pacote de atualização de versão, caso não encontre entre em contato com o suporte.