eDocs - NFS-e Betha - E92 - Esse RPS foi enviado para a nossa base de dados, mas ainda não foi processado
Incidente
Aos serem enviadas NFS-e para Prefeitura atendida pelo Fornecedor Betha Sistemas, as NFS-e ficam com status de "Enviada" no eDocs e não são autorizadas.
Ao realizar a verificação dos Logs XMLs, é possível verificar que o eDocs está enviando a Consulta do Lote, no entanto, no retorno da Consulta do Lote é retornada a seguinte mensagem:
<Codigo>E92</Codigo>
<Mensagem>Esse RPS foi enviado para a nossa base de dados, mas ainda não foi processado</Mensagem>
<Correcao>Faça uma nova consulta mais tarde.</Correcao>
Mensagem sem as tags HTML:
E92
Esse RPS foi enviado para a nossa base de dados, mas ainda não foi processado
Faça uma nova consulta mais tarde
Causa
Essa situação ocorre por uma demora no processamento de Lotes de RPS pela Prefeitura.
Solução
Importante
A situação reportada não é um problema do sistema eDocs, mas sim um problema no sistema da Prefeitura. Desta forma, seguem procedimentos que você poderá adotar para sanar essa situação:
1- Colete os Logs XMLs do eDocs com relação a comunicação com a Prefeitura para esse cenário;
2- Entre em contato com o Suporte da Prefeitura relatando o problema;
3- Após o retorno da Prefeitura relatando que a situação tenha sido resolvida, acompanhe os Logs de comunicação no eDocs e valide que as NFS-e tenham sido autorizadas.
Observação
O fluxo do processo de emissão do eDocs pode ser verificado no artigo ERP - eDocs NFS-e Emissão - Como funciona o fluxo padrão de emissão de uma NFS-e para Prefeituras que utilizam leiaute baseado no padrão ABRASF
Importante
Essa situação não é um problema do eDocs, mas sim um problema de demora da Prefeitura em efetuar o processamento dos Lotes XMLs.