Globaltec UAU – Gerar Boleto – Banco emissor de boletos do PjBank está indo diferente do padrão de cobrança
Incidente
No módulo Vendas, ao gerar boletos do intermediário digital PjBank, os boletos estão com o banco emissor diferente do que está vinculado ao padrão de cobrança.
Causa
Este incidente ocorre ao gerar boletos do intermediário digital PjBank, pois o sistema não envia para o PjBank qual será o banco emissor.
Solução
No PjBank a conta que está no padrão de cobrança é referente a conta que irá receber o dinheiro dos boletos pagos, quando feito o seu credenciamento. Nesses casos, não precisa ter uma conta digital própria do PJBank mas ele indica em qual conta será feita o repasse. Não tem nada relacionado ao qual banco irá emitir o boleto. Quando enviado as cobranças para o PJBank emitir, o sistema não envia nenhuma informação referente ao banco emissor. É autenticado com os dados da conta credenciada e enviado os valores e dados do pagador. A escolha de qual banco irá gerar a cobrança é feita pelo próprio PJBank. O UAU, só utiliza as informações dos boletos com os dados retornados, como linha digitável, campo livre, código de barras, etc. Se ao imprimir o boleto, está vindo com as informações do Banco do Brasil, por exemplo, quer dizer que o PJBank usou esse banco para a emissão do boleto. Na documentação do PjBank diz o seguinte: https://docs.pjbank.com.br/#4b192cf6-ed9f-4a3d-b79d-2066d23d8fa3. Ao credenciar a conta para recebimento com boleto bancário, um dos tópicos é esse:
‘PJBank pode emitir automaticamente boletos através dos bancos Santander, Itaú, Banco do Brasil ou qualquer outro banco parceiro, não sendo permitido escolher entre eles.’ Pode validar com o atendimento do PJBank porque houve a alteração do banco emissor. Segue esse e-mail para atendimentos com o PJBank: atendimento@pjbank.com.br.