RONDA SENIOR – CSM Center – CSMCenter] Não foi possível iniciar a CSM Center. Recurso "conexão com a base de dados" não encontrado ou não disponível. Causa: Error in allocating a connection. Cause: Connection could not be allocated because: Cannot open
Incidente
No CSM Center ao realizar a configuração de conexão de banco, para banco de dados SQL Server, é apresentada a mensagem: [CSMCenter] Não foi possível iniciar a CSM Center. Recurso "conexão com a base de dados" não encontrado ou não disponível. Causa: Error in allocating a connection. Cause: Connection could not be allocated because: Cannot open database "NOMEDABASE" requested by the login. The login failed. ClientConnectionId:ba9c9505-0ff6-4b2c-abcd-7cd9989ba9f0]].
Causa
Esta mensagem é apresentada, pois o CSM Center não está conseguindo se comunicar com o banco de dados, porque não reconhece a configuração realizada no CSM Center Config.
Solução
Para que a mensagem não seja apresentada ao ao realizar a configuração de conexão de banco, para banco de dados SQL Server, realize os passos a seguir:
1. Acesse via web o Glassfish: http://nomedoservidor:4949;
2. Entre no menu: Resources / JDBC / JDBC Connection Pools / com.senior.seguranca.csmcenter.EmbeddedConnectionPool;
3. Acesse a Guia Additionall Properties;
4. Remova todas as informações que constam nesta guia;
5. Clique em Add Property;
6. Adicione em Nome: URL;
7. Acesse o SeniorConfigCenter;
8. Acesse o menu: Banco de Dados / Gestão de Pessoas ou Banco de Dados / Ronda Senior;
9. Copie toda a informação que se encontra no menu: URL para Conexão JDBC;
10. Cole essa informação no Glassfish no campo: Value;
11. Clique em Save;
12. Reinicie o serviço do CSM Center.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.