HCM – Banco de horas – Conta do banco de horas fechada
Incidente
No módulo Gestão do Ponto, algumas contas aparecem fechadas e não foi identificado o motivo.
Causa
Este incidente pode ocorrer quando for feita uma integração dos eventos do ponto para a folha e no momento da integração o parâmetro Integração para Rescisão foi assinalado com o Valor 'S'.
Quando o processo de integração é feito para rescisão, o módulo Controle de Ponto chama o Webservice de fechamento do banco de horas e faz com que a conta do banco de horas dos colaboradores que estão na abrangência do processo sejam fechadas, já que neste caso é entendido que por se tratar de uma rescisão, o saldo do banco de horas deve ser integrado para pagamento/desconto.
Solução
Para identificar se houve um processo de integração para rescisão, realize os passos a seguir:
1. No módulo Controle de Ponto e refeitório acesse o menu Diversos / Log / Listar;
2. Selecione o relatório de número 001 - Log dos processamentos;
3. Informe as datas que você irá verificar os logs, e no campo Tipo de processamento informe o valor '3' (que se refere ao log da geração de eventos) e clique em ok;
3. Identifique se houve uma integração para rescisão, busque pela informação Calcular para rescisão Adm. Pessoal = 'S', conforme o exemplo da imagem abaixo:
Observação:
Caso houve a integração para rescisão e o colaborador pertence ao módulo Gestão do Ponto, a conta do banco de horas será fechada com a data informada no campo Data da demissão, que pode ser visto no log gerado.
Importante:
Na ocasião de ter sido o processo de geração de eventos que fez com que a conta fosse fechada, a informação do usuário que realizou o fechamento será gravada com o nome do usuário batch, conforme o print abaixo:
Isso porque quem faz o fechamento do banco de horas é um Webservice do módulo Gestão do ponto, e o usuário batch é o usuário utilizado na execução desta ação.
O usuário batch pode ser identificado no SeniorConfigCenter, no menu Sistemas / Gestão de Pessoas / Gestão do Ponto.