HCM – Gestão do Ponto – Lentidão/Instabilidade no Gestão do Ponto
Incidente
No módulo Gestão do Ponto, ao executar alguma rotina como o Cálculo de Apuração ou até mesmo acessando alguma tela, ocorre uma instabilidade/lentidão. E ao verificar o log do Glassfish é apresentado o erro "Connection pool exhausted":
Causa
Esta mensagem é apresentada quando estoura o limite de conexões com o banco de dados.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o SeniorConfigCenter;
2. Acesse Banco de Dados / Gestão de Pessoas;
3. Clique no botão "Avançado";
4. Altere para "50" o campo "Quantidade mínima para pool de conexões" e altere para "200" o campo "Quantidade máxima para pool de conexões:
5. Reinicie todos os domínios do Glassfish.
Observação
Estas parametrizações foram validadas pela área de manutenção do produto.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.