HCM - S-1210 - Não gera S-1210 de versões anteriores do eSocial
Incidente
No módulo Administração de Pessoal, ao tentar gerar um S-1210 retificador de versões anteriores do eSocial, o mesmo não é gerado.
Causa
Esse incidente ocorre pois ao retificar o leiaute S-1210, ele será gerado com a versão mais recente do eSocial. Portanto, é necessário retificar também o leiaute S-1200 para garantir que ambos estejam na mesma versão do eSocial e sejam gerados corretamente.
Solução
Para que esse incidente não ocorra, realize os passos a seguir:
1. Acesse o módulo Administração de Pessoal;
2. Acesse eSocial / Eventos Periódicos / Envio Declaração Mensal,
3. Informe a competência que precisa ser retificada;
4. No campo "Tipo de Envio", selecione a opção 2 - Total, onde irá retificar o leiaute enviado na versão anterior do eSocial;
5. Selecione o leiaute S-1200 e no ícone Seleção, filtre apenas o colaborador em questão:
Importante
Ao selecionar a opção 2 - Total, um novo S-1200 será gerado para essa competência, onde irá gerar um S-3000 excluindo o leiaute S-1210 enviado anteriormente.
6. Acesse eSocial / Consulta Pendências, processe o S-300 de exclusão do S-1210;
7. Em seguida processe o S-1200 de retificação e aguarde o retorno do recibo;
8. Acesse eSocial / Eventos Periódicos / Envio Declaração Mensal e gere um novo o S-1210.