EDOCS – Emissão NF-e – Rejeição: 999 - Server was unable to process request. ---> The type initializer for 'Sefaz.NFe.Lib.Conf.Configuration' threw an exception
Incidente
Ao emitir uma NF-e, no eDocs as notas são rejeitadas pelo seguinte motivo: 999 - Server was unable to process request. ---> The type initializer for 'Sefaz.NFe.Lib.Conf.Configuration' threw an exception. ---> A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) ---> The network path was not found.
Causa
Essa situação ocorre quando os webservices da SEFAZ estão passando por alguma indisponibilidade.
Solução
Para tratar esse cenário poderá ser feito os seguintes procedimentos:
1. Entre em contato com o suporte técnico da SEFAZ de origem e verifique o motivo da instabilidade e a previsão de retorno do ambiente normal;
1.2. Ao normalizar o serviço da SEFAZ, no Gestão Empresarial | ERP acesse a tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal e emita a nota novamente;
2. Caso o serviço da SEFAZ demora para estabilizar, no eDocs acesse a tela NF-e / Controle de Contingência e ative a contingência para a filial em questão;
2.1. No Gestão Empresarial | ERP acesse a tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal e emita a nota novamente;
Observação
Para mais informações sobre o controle de contingência no eDocs, clique aqui para acessar o Portal de Documentação e consulte o Manual do usuário do eDocs, acessando a opção Documentos Eletrônicos / NF-e / Controle de contingência.