Globaltec UAU – Produtos Gerais – Não é possível alterar o tipo de contrato personalizado
Incidente
Ao modificar o tipo de contrato de uma unidade personalizada, o sistema emite um alerta: Não é permitido alterar o Tipo de contrato da personalização quando seu status for: 1 - Vendido; 3 - Proposta; 4 - Quitado; 5 - Escriturado; 6 - Em venda; 9 - Em acerto; 10 - Dação.
Causa
Este incidente ocorre, pois a unidade personalizada não está mais com status 0 - Disponível, ficando ilegível para sofrer essa alteração.
Solução
Para realizar a alteração do tipo de contrato é necessário que a unidade esteja com status 0 – Disponível. Caso a unidade não esteja mais disponível não será possível alterar tipo de contrato.