eDocs - Recebimento - A conta informada já está configurada. Não é possível configurar duas vezes a mesma conta
Incidente
No eDocs Em Configurações / Empresas / Recebimento / E-mail, ao efetuar o cadastro de uma conta de e-mail, quando clica em salvar É apresentada a mensagem: A conta informada já está configurada. Não é possível configurar duas vezes a mesma conta
Causa
Essa mensagem é apresentada pois:
- ocorreu um conflito por mais de uma sessão do sistema aberta ao mesmo tempo;
- serviço foi parado, reiniciado enquanto e-mail está sendo salvo.
Observação: Geralmente quando isso ocorre o campo SEQEMP fica vazio, não sendo possível salvar o e-mail.
Solução
Para que essa mensagem não seja apresentada, execute os passos abaixo:
1. Acesso o banco de dados onde o eDocs está instalado;
2. Execute os comandos abaixo:
- SELECT * FROM N100REC
Observação: Salvar o SEQREC da empresa que está como SEQEMP null.
- SELECT * FROM N100EMP WHERE CNPEMP = CNPJ_EMPRESA
Observação: Salvar o SEQEMP e deverá retornar somente um resultado.
-
UPDATE N100REC SET SEQEMP = SEQEMP_SALVO WHERE SEQREC = SEQREC_SALVO
Observação
A conta de e-mail ficará visível na tela de cadastro de e-mail pra recebimento.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.