eDocs – Recebimento – O sistema parou de receber os e-mails de documentos eletrônicos após a alteração de senha da conta de e-mail
Incidente
Foi alterado a senha da conta de e-mail no cadastro da conta recebimento no eDocs, porém os documentos eletrônicos ainda permanecem sem integrar no sistema.
Observação
Esse cenário pode ocorrer na rotina de envio de e-mails também.
Causa
Essa situação ocorre para contas de e-mails que exigem autenticação em dois fatores (OAuth2), onde foi realizado a alteração de senha no sistema mas não foi refeito o processo de parametrização da conta pelo Configurador do eDocs.
Solução
Quando é realizado a alteração de senha, é necessário também refazer a configuração da conta pelo Configurador do eDocs. Isso é necessário pois o token é gerado com base na senha da conta, se a senha é alterada o token fica inválido.
Desta forma, para gerar o novo token, siga as orientações abaixo:
1. Para contas Microsoft OAuth2:
1.1. Acesse a pasta de instalação do eDocs;
1.2. Encontre o arquivo Authcache e exclua;
Importante
- Para realizar essa operação em um ambiente Cloud, entre em contato primeiramente com equipe de Suporte para validação e eventual apoio;
- Caso existam mais contas Outlook configuradas no ambiente a exclusão desse arquivo irá causar impacto em todas elas, tendo assim sua funcionalidade afetada e sendo necessário efetuar o processo de autorização para todas as contas novamente, uma a uma. Caso não possua acesso a todas as contas, não recomenda-se fazer esse processo.
1.3. Após a exclusão, execute os passos de autorização do Outlook novamente. Clique aqui para consultar a documentação referente ao processo.
2. Para contas Google OAuth2:
Importante
- Para que seja habilitado novamente a autorização do Gmail, é necessário que o arquivo OAuth2Google.conf seja removido;
- Para realizar essa operação em um ambiente Cloud, entre em contato primeiramente com equipe de Suporte para validação e eventual apoio;
- Caso existam mais contas Gmail configuradas no ambiente (mesmo que não seja ambiente Cloud Senior) a exclusão desse arquivo irá causar impacto em todas elas, tendo assim sua funcionalidade afetada e sendo necessário efetuar o processo de autorização para todas as contas novamente, uma a uma. Caso não possua acesso a todas as contas, não recomenda-se fazer esse processo. Neste caso, acione o Desenvolvedor do eDocs para apoio.
2.1. Acesse a pasta de instalação do eDocs;
2.2. Encontre o arquivo OAuth2Google.conf e exclua;
2.3. Após a exclusão, execute os passos de autorização do Gmail novamente. Clique aqui para consultar a documentação referente ao processo.
Importante
É necessário que você execute este procedimento usando o mesmo usuário configurado no serviço do eDocs. Caso seja gerado com outro usuário o processo de comunicação com Servidor de E-mail não irá funcionar.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.