ERP – eDocs Retorno ao ERP – Crítica: ERRO: Erro ao atualizar o pedido XXY: Usuário não tem permissão para cancelar o pedido (não pode alterar a situação do pedido)
Incidente
Ao realizar o cancelamento de uma NF-e e ele ser autorizado, no momento em que o retorno é enviado ao Gestão Empresarial | ERP está sendo retornada a mensagem: Crítica: ERRO: Erro ao atualizar o pedido XXY: Usuário não tem permissão para cancelar o pedido (não pode alterar a situação do pedido).
Causa
Essa situação ocorre por parametrizações incorretas no cadastro do usuário utilizado para realizar os retornos do eDocs ao Gestão Empresarial | ERP.
Solução
Para que o retorno seja processado corretamente ao Gestão Empresarial | ERP, é necessário que seja revisada a permissão do usuário responsável por processar o retorno. Para isso, valide os passos abaixo:
1. Acesse a tela Configurações / Empresas, aba Integração no eDocs e verifique o campo Usuário integração ERP:
2. No Gestão Empresarial | ERP, acesse a tela F099UVE - Cadastros / Usuários / Parâmetros por Gestão / Vendas e Faturamento, localize o cadastro do usuário em questão e revise a permissão Alterar Situação Pedido:
3. Após ajustar a permissão, consulte a nota novamente no eDocs em NF-e / Emissões / aba Cancelamentos, e clique no botão Reenviar Retorno:
Atenção
Se for utilizada customização por filial para retorno, então o usuário é definido no campo Usuário integração ERP da tela Configuração / Filial, aba Filial: