EDOCS – Consulta URL – Não foi possível obter resposta da URL 'https://cascavel.atende.net/atende.php?pg=rest&service=WNERestServiceNFSe'. O servidor remoto retornou um erro: (401) Não Autorizado
Incidente
Ao consultar uma URL do webservice de uma Prefeitura atendida pelo Fornecedor IPM pela tela Configurações / Consultas URLs, está retornando a mensagem: Não foi possível obter resposta da URL 'https://cascavel.atende.net/atende.php?pg=rest&service=WNERestServiceNFSe'. O servidor remoto retornou um erro: (401) Não Autorizado.
Observação: Como exemplo foi usado a URL da prefeitura de Cascavel/PR.
Causa
Essa situação ocorre pois as Prefeituras atendidas pela IPM exigem um login para comunicação com o webservice.
Solução
Para tratar este cenário, siga as orientações abaixo:
1. No servidor onde está a instalação do eDocs, copie a URL e cole em um navegador web (Chrome, Edge, etc):
2. Informe o usuário e senha, conforme disponibilizado pela Prefeitura.
Observação
- Conforme consta na documentação do sistema, o botão de testar a consulta de URL é verificada a disponibilidade do webservice selecionado. Em alguns casos o sistema pode solicitar a informação de um certificado digital para efetuar o teste de conexão. Nem sempre é possível verificar a disponibilidade do webservice desta opção, nesse caso, pode-se copiar o endereço do webservice mostrado na tela e colar em um navegador para realizar o teste. Para mais informações, acesse aqui o Portal de Documentação Senior, pesquise "Consulta de URLs" e localize a documentação sobre esta rotina no módulo eDocs.