ERP – NFS-e IPM – Crítica lote: 99999 / The underlying connection was closed: The connection was closed unexpectedly
Incidente
Ao emitir uma NFS-e para a Prefeitura de Indaial atendido pelo fornecedor IPM, a nota é rejeitada e nos detalhes do lote consta 'Crítica: 99999'. Ao consultar o arquivo de log Sde.log temos:
The underlying connection was closed: The connection was closed unexpectedly.
at System.Net.HttpWebRequest.GetResponse() at Senior.SapiensNfe.Processos.Service.Nfse.Customizado.IpmNfseBusiness.ObterRetornoWebRequest(HttpWebRequest httpWebRequest) at Senior.SapiensNfe.Processos.Service.Nfse.Customizado.IpmNfseBusiness.ExecutarRequisicao(NameValueCollection arquivos, NameValueCollection parametros, TipoWebService tipoWebservice, String identificador, String inscricaoMunicipal, Filial filial, ISession sessao)
at Senior.SapiensNfe.Processos.Service.Nfse.Customizado.IpmNfseBusiness.RecepcionarLoteRps(LoteRps loteRps, ISession sessao)
Ao realizar o teste de conexão da URL do webservice da Prefeitura via browser retorna:
Causa
Essa situação ocorre quando o serviço do eDocs não consegue se comunicar com o WS da Prefeitura.
Solução
Para tratar este cenário siga as orientações abaixo:
1. Entre em contato com o responsável pela TI interna da empresa e solicite ao mesmo para validar a comunicação com os webservices da Prefeitura;
2. Após o webservice estar comunicando, acesse a tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal e emita a nota novamente.