eDocs - E-mail Google/Outlook OAuth2 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond
Incidente
Ao configurar uma conta de e-mail para recebimento é apresentado a mensagem A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond ao ser efetuado o teste de conexão.
Causa
Essa mensagem é gerada quando existe uma restrição de comunicação no ambiente, normalmente a um bloqueio no firewall que impede a comunicação com a porta informada.
Solução
Para verificar se existe um bloqueio na porta podemos utilizar, por exemplo o comando Telnet. Para iniciar um teste de Telnet em uma porta no Windows, execute os passos a seguir:
1. Abra o prompt de comando;
2. Digite na janela do prompt de comando:
telnet <server> <port>
onde <server> é o nome do host ou endereço IP do servidor e <port> é a porta que deseja conectar;
3. Pressione Enter;
Observação:
Caso exista um bloqueio na porta informada uma mensagem será retornada, como a que consta na imagem:
4. Após confirmação do bloqueio existente, efetue a liberação da porta e um novo teste de conexão deve ser realizado.
Importante
A porta 143 que aparece na mensagem foi utilizada como exemplo, o bloqueio pode existir para as mais variadas portas, isso irá depender de cada ambiente.
Esse bloqueio não é feito pelo eDocs, se trata da parte de infraestrutura do ambiente em que o eDocs está instalado.