ERP – eDocs NF-e – Conta financeira XXXX não está liberada para este usuário PADRÃO
Incidente
No eDocs, ao cancelar uma nota e o cancelamento ser rejeitado pela SEFAZ o retorno ao ERP GOUP não está ocorrendo, é retornada a mensagem: ERRO: Houve problemas na solicitação do cancelamento/inutilização e não foi possível retornar o documento a sua situação original: Não foi possível fechar o(a) : Nota Fiscal Nº X.XXX, Série XX, Cliente X.XXX - Não foi possível fechar a nota fiscal de saída. - Erro ao baixar estoque: Conta financeira XXXX não está liberada para este usuário PADRÃO - Utilizando os seguintes dados: - Critério de busca: "CD". - Opção do critério de busca utilizada: "C" - PRODUTO/SERVIÇO: "XXXX". - Critério do rateio: 3 - DESPESA - CONTA X C.CUSTOS. - Tipo do rateio: "U" - Centro de custos: " ".
Causa
Esta mensagem é retornada, pois o usuário responsável pelo retorno da situação da nota tem relacionamento com outras contas financeiras diferente da informado no rateio do produto.
O relacionamento de usuários com a conta financeira é realizado na tela F099UXR - Cadastros / Usuários / Relacionamentos / Usuários X Relacionamentos, e se houver um relacionamento gravado nesta tabela o sistema passa a validar usuário x conta financeira.
Uma vez efetuado algum relacionamento para o usuário, para todos os processos de rateios, será consistido/verificado se o usuário possui ou não permissão para rateio para determinado Centro de Custo / Conta Contábil / Conta Financeira.
Solução
Para que a mensagem não seja apresentada e ocorra o retorno da situação da nota, realize os passos a seguir:
1. Acesse o menu Configurações / Empresa / Integração no eDocs;
1.1. Acesse a guia Integração;
1.2. Verifique e anote o usuário informado no campo Usuário Integração ERP;
2. Acesse a tela F099UCA - Cadastros / Usuários / Cadastro;
2.1. Clique na lupa para buscar pelo usuário que anotou no passo 1.2:
2.2. Anote o código desse usuário;
3. Acesse a tela F099UXR - Cadastros / Usuários / Relacionamentos / Usuários X Relacionamentos;
3.1. Informe o Usuário para Mostrar e o sistema sugerirá o mesmo usuário no campo Usuário para Processar;
3.2. Informe nos Relacionamentos a opção Contas Financeiras:
3.3. Clique no botão Mostrar;
3.4. Selecione a Conta financeira desejada e processe caso queira vincular o usuário a essa conta financeira, ou se preferir pode excluir o relacionamento, desmarcando a conta financeira relacionada ao usuário, e processando para que fique inativo;
4. Acesse o eDocs novamente;
4.1. Acesse a Guia NF-e / Emissões / Cancelamentos;
4.2. Selecione a nota que apresentou erro no retorno;
4.3. Clique no botão Reenviar retorno e retornará sem erros a rejeição do cancelamento.
Observação
Essa mensagem pode ser apresentada para Centro de Custo e Conta Contábil dependendo do processo utilizado pela Empresa, o procedimento será o mesmo citado acima para todos os casos, mas no passo 3.2. deverá escolher a opção adequada de acordo com a mensagem de erro no retorno.