ERP – Controle de Bens– Nenhum registro disponível para consulta
Incidente
No módulo Gestão de Patrimônio, ao tentar acessar as informações de cadastros de bem é apresentada a mensagem: Nenhum registro disponível para consulta.
Causa
Esta mensagem é apresentada, pois o usuário não tem acesso as informações ou não há bens cadastrados nessa filial.
Solução
Para que a mensagem não seja apresentada ao efetuar a consulta, valide os passos a seguir:
1. Com outro usuário, acesse a tela F670BEM - Controladoria / Gestão de Patrimônio / Controle de Bens / Bem / Individual e verifique se a empresa possui bens cadastrados;
2. Acesse a base de homologação com o usuário e verifique se o incidente também ocorre;
3. Verifique com usuário administrador se não foi criado bloqueios de acesso a tais informações via SGU, para o usuário em que o incidente ocorre;
4. Verifique se existe Regras por evento, na tela F670BEM - Controladoria / Gestão de Patrimônio / Controle de Bens / Bem / Individual. Para essa validação clique em qualquer espaço da tela com o botão direito, após selecione 'Regras por eventos':
4.1. Todos os eventos devem ser verificados, em caso de regras, estas devem ser analisadas para descartar o bloqueio do usuário;
5. Na tela F099UAB - Cadastros / Usuários / Abrangências verifique as abrangências deste usuário;
6. Acesse F098REG - Cadastros / Identificadores e parâmetros / Identificador de Regras e verifique se está ativo os identificadores GER-000SELEF01 ou GER-000SELEF02. Se sim, inative os mesmo e simule nova consulta na tela com o usuário. Se as informações retomarem é necessário validar a regra inserida nos ID's;
7. Validar se não há conflitos entre os acessos disponibilizados via SGU, para validar é necessário testar um a um.