ERP - eDocs NFS-e IPM - {"retorno":{"msg":"Acesso Negado!","sis":false,"code":401}}
Incidente
Ao transmitir uma NFS-e para a prefeitura onde o fornecedor é IPM, ela é rejeitada e nos eventos consta a crítica: {"retorno":{"msg":"Acesso Negado!","sis":false,"code":401}}.
Causa
Esta mensagem é apresentada quando o acesso ao Web Service da prefeitura exige autenticação e o usuário não consegue efetuar essa autenticação ou não foi localizado. Possivelmente o usuário e senha estão incorretos.
Solução
Para resolver essa questão execute os passos a seguir:
1. Acesse o menu Configurações / Filiais, aba NFS-e, sub-aba Parâmetros Município. Clique aqui e veja todos os campos que são de preenchimento obrigatório;
2. Preencha os campos Senha e Usuário;
3. Após ajustada a situação, realize o reenvio da nota no Gestão Empresarial | ERP através da tela F140CAN_RFNF - Mercado / Gestão de Faturamento e Outras Saídas / Notas Fiscais de Saída / Emissão e cancelamento / Nota fiscal;
Importante
- Mensagens semelhantes com o código 401 podem aparecer para outros fornecedores, para verificar as informações que devem ser preenchidas nos Parâmetros Município, clique aqui e acesse a documentação do fornecedor da prefeitura;
- Caso haja necessidade de envio de XMLs para a Prefeitura, você poderá coletar os Logs XML para o processo e enviá-los para a Prefeitura. Para isso, acesse o artigo ERP – eDocs Log XML – Como coletar os XMLs trafegados entre eDocs e SEFAZ/Prefeituras (Logs XML).