ERP - eDocs NF-e - 999 - O Digest Value da NF-e XX é diferente do Digest Value registrado na SEFAZ. Digest Value da nota: ZZ, digest value na Sefaz: XX
Incidente
No eDocs ao tentar emitir a NF-e ela é rejeitada com uma rejeição interna retornada pelo eDocs com a seguinte mensagem: 999 - O Digest Value da NF-e XX é diferente do Digest Value registrado na SEFAZ. Digest Value da nota: ZZ, digest value na Sefaz: XX.
Observação
Em algumas situações, a NF-e poderá ficar travada com status de 'Enviada' no eDocs.
Causa
Essa situação pode ocorrer por dois motivos:
- Quando o arquivo XML armazenado pelo eDocs apresenta o Digest Value diferente do Digest Value do arquivo autorizado pela SEFAZ, por qual motivo que seja;
- Quando utilizada uma versão do eDocs anterior à 5.8.15.13, e a NF-e foi rejeitada pela SEFAZ, sendo que anteriormente ela seria Denegada (conforme mudanças da NT 2024.001). Neste caso, geralmente a situação envolve a rejeição '302 - Irregularidade Fiscal do Destinatário'.
Solução
Para resolver essa situação, siga os passos a seguir, de acordo com o cenário da NF-e:
1. Caso a NF-e esteja devidamente autorizada na SEFAZ/denegada/cancelada
Atenção
Antes de fazer as alterações, verificar se a NF-e que consta na SEFAZ é a mesma que consta no eDocs.
1.1. Copie e salve o Digest Value que consta na SEFAZ para a NF-e em questão. Se necessário, acesso o Portal Nacional ou Estadual da NF-e para validar o Digest Value correto;
1.1.1 Execute o comando abaixo para pesquisar a NF-e no banco de dados, salve a informação que consta no campo SEQNFE;
SELECT * FROM N130NFE
WHERE NUMNFE = NUMERO_NFE
AND SEQFIL = CNPJ_FILIAL
Importante
O comando deverá retornar somente um registro.
1.2. Após selecionado o select e com o SEQNFE salvo, execute o comando abaixo alterando os paramentos em DIGEST_VALUE_SEFAZ e SEQNFE_SALVO para os dados salvos nos passos anteriores;
UPDATE N130NFE
SET DIGVAL = 'DIGEST_VALUE_SEFAZ'
WHERE SEQNFE = SEQNFE_SALVO
AND SEQFIL = CNPJ_FILIAL
1.3. Com o update executado, volte ao eDocs e consulte o documento novamente, o status deverá ser atualizado para a mesma informação que consta na SEFAZ.
2. Caso a NF-e não tenha sido autorizada na SEFAZ (situação envolvendo a mudança da NT 2024.001, que retira o status de Denegação)
Importante
- As orientações indicadas abaixo se aplicam para Clientes que utilizam versão do eDocs anterior à 5.8.15.13 e tenham emitidas NF-e em data posterior à 16/09/2024 em Produção ou 01/07/2024 em Homologação (datas definidas na NT 2024.001);
- A utilização de versão do eDocs anterior impacta na interpretação das alterações promovidas pela SEFAZ através da NT 2024.001, impedindo o correto processamento do sistema;
- A correção definitiva dessa situação exige que o sistema eDocs seja atualizado para uma versão 5.8.15.13 ou posterior. As orientações descritas abaixo servem como ação paliativa para destravar o documento que tenha sido emitido em versão desatualizada.
2.1. Confirme no 'CCC - Cadastro Centralizado de Contribuinte' e consulte se o Destinatário dessa NF-e (CNPJ/Inscrição Estadual) está de fato irregular/inativo/inapto na SEFAZ;
Observação
O link de acesso ao 'CCC - Cadastro Centralizado de Contribuinte' você encontrará em buscas pela Internet (é um Portal mantido pela SEFAZ-RS). O link não será fixado neste artigo porque ele pode mudar, conforme definição da SEFAZ.
2.2. Execute o comando abaixo para pesquisar a NF-e no banco de dados, salve a informação que consta no campo SEQNFE;
SELECT * FROM N130NFE
WHERE NUMNFE = NUMERO_NFE
AND SEQFIL = CNPJ_FILIAL
Importante
O comando deverá retornar somente um registro.
2.3. Execute o comando abaixo para tornar a NF-e rejeitada no eDocs:
Sendo assim para solução de causa raiz deverá ser realizada a atualização, como contorno para essa nota
UPDATE N130NFE SET SITNFE = 8 WHERE SEQNFE = SEQNFE_SALVO AND NUMNFE = NUMERO_NOTA AND SEQFIL = CNPJ_FILIAL
2.4. A partir da Rejeição da NF-e no eDocs e retorno ao Gestão Empresarial | ERP, a NF-e poderá ser inutilizada. Caso você queira reemitir a NF-e com os mesmos dados, deverá garantir que o Destinatário não esteja mais com pendências junto à SEFAZ, do contrário, o mesmo problema poderá ocorrer novamente (se a emissão ocorrer ainda em versão desatualizada do eDocs).
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.