ERP MEGA - MegaConnectionManager - Não é iniciado automaticamente o serviço do Windows
Incidente
Ao reiniciar o Servidor de Aplicação, o serviço do MegaConnectionManager.exe não é iniciado automaticamente.
Causa
Este incidente ocorre, pois o Servidor Mega também é o servidor de Aplicação e de Banco de Dados, sendo assim, o MegaConnectionManager.exe não consegue iniciar automaticamente antes da inicialização do banco.
Solução
Para solucionar este incidente e o MegaConnectionManager.exe iniciar automaticamente através do serviço do Windows, realize os processos a seguir:
1. No Servidor de Aplicação, clique no Iniciar do Windows e abra o Executar;
2. Digite Services.msc e clique em OK;
3. Localize o serviço MegaConnectionManager e clique sobre ele com o botão direito em Propriedades;
4. Clique na aba Dependências;
5. Verifique se possui alguma Dependência do Oracle nele;
5.1 Caso não possua a dependência realize a configuração, para isso verifique o artigo: Como realizar a dependência do Serviço do Windows com o Oracle.
5.2 Caso já possua dependências com o Oracle, verifique se a senha do usuário no Servidor de aplicação está correta, para isso verifique o artigo: Como realizar a alteração do usuário e senha do MegaConnectionManager.exe como serviço do Windows.
Após a validação destes pontos o MegaConnectionManager iniciará com sucesso sempre que reiniciar o Servidor de Aplicação / Banco de Dados.