ERP – Ordens de Compra – Demora excessiva e não carrega solicitação de compra de serviço para gerar ordem de compra mesmo aplicando filtro com fornecedor e código do serviço
Incidente
No módulo de Compras, ao tentar gerar ordem de compra via solicitação de compra de serviço, é apresentada uma demora excessiva e não carrega solicitação de compra de serviço para gerar ordem de compra mesmo aplicando filtro com fornecedor e código do serviço na tela.
Causa
Verificado que o incidente ocorreu devido aplicação de filtros na tela inadequadamente.
Solução
Foi observado essa demora excessiva e não carregamento solicitação de compra de serviço para gerar ordem de compra mesmo aplicando filtro com fornecedor e código do serviço na tela F420OSC - Suprimentos / Gestão de Compras / Ordens de Compra / Via Solicitação de Compra.
Para diagnóstico e resolução do cenário, foram realizados os seguintes passos:
1. Orientado que no campo Selecionar fosse escolhido Serviços. Assim, o Gestão Empresarial | ERP faz a carga somente das solicitações de serviço ao clicar no botão Mostrar;
Também foi indicado que através do botão Seleção, que abre a tela F420SOS - Ordens de Compra via Solicitação de Compras - Seleção, fosse preenchido o respectivo serviço que deseja gerar a ordem de compra a partir da solicitação de compra já cadastrada e apta para ser utilizada neste processo.
2. Mesmo com as orientações acima, do passo 1, o comportamento persistiu.
Então observou-se que na tela F420SOS - Ordens de Compra via Solicitação de Compras - Seleção, aberta partir do clique no botão Seleção da tela F420OSC - Suprimentos / Gestão de Compras / Ordens de Compra / Via Solicitação de Compra, havia sido marcado checkbox 'Não';.
Esse checkbox Não, tem a finalidade de definir uma negação para a informação que está preenchida no campo, ou seja, ao inserir um código de serviço e marcar o checkbox, o sistema passa a não carregar esse serviço informado e carregar todos os demais serviços que estejam pendentes para gerar ordem de compra via solicitação de compra.
Isso justificou a demora excessiva apresentada para carregar os registros e além disso também o fato de mesmo com a demora o registro ainda não ser carregado na tela.
Imagem abaixo destaca a marcação do checkbox citado:
3. Após desmarcar o checkbox 'Não', o carregamento da solicitação de compra na tela voltou a ser rápido trazendo as devidas informações e permitindo seguir com a geração da ordem de compra.