HCM - Portal do candidato - Autenticação via Linkedin ou Facebook não funciona
Incidente
No módulo Gestão de Recrutamento e Seleção, ao acessar o portal do candidato e tentar autenticar via Linkedin ou Facebook nada acontece em tela, permanecendo na tela de login do portal, mesmo que todos os pré-requisitos da integração já tenham sido configurados.
Causa
Este incidente pode ocorrer devido a algum problema na configuração deste tenant na arquitetura da plataforma.
Solução
Para comprovar que se trata do mesmo incidente, realize os seguintes passos:
1. Acesse o portal do candidato;
2. Pressione F12 ou utilize o botão direito do mouse em Inspecionar, do qual pode variar de navegador para navegador;
3. Clique sobre um dos ícones do Linkedin ou Facebook;
4. Na aba network verifique se esta ocorrendo alguma mensagem na primitiva https://platform.senior.com.br/auth/OAuthLoginServlet com a descrição de Erro: 401 - A URL não está redirecionand. Confira a configuração do seu serviço de autenticação;
4.1. Caso a mensagem seja diferente desta, é necessário entrar em contato com o suporte do produto para seguir com a investigação de outras possíveis causas;
5. Uma vez que ocorra o erro mencionado no item 4, é necessário entrar em contato com o Suporte X Platform e Performance Corporativa para ser aberto um serviço para o SRE da plataforma verificar as configurações de claims, URI Redirect, portas entre outras configurações da plataforma que podem estar impactando neste cenário;
5.1. Anexe junto a este ticket de atendimento as evidências deste cenário acima junto a informação do item 4 deste artigo.