HCM – Efetivação de Candidato – Candidato já efetivado por outro usuário / O Candidato já está admitido
Incidente
No Administração de Pessoal ao realizar a efetivação do candidato está ocorrendo mensagens conforme segue:
- Candidato já efetivado por outro usuário;
- O candidato já está admitido.
Causa
Este incidente pode ocorrer nas seguintes situações:
- Quando a conexão com o sistema foi interrompida (ex.: Queda de energia, problemas na rede, etc). Dessa forma ficou registros travados na tabela responsável;
- Quando o colaborador já estava efetivado e cadastrado na folha de pagamento, mas foi excluído o cadastro dele na folha pois tinha informações incorretas e em seguida ao tentar efetivar novamente o candidato não é possível efetivar.
Solução
Para corrigir essa informação e remover o registro que está travada diretamente da base de dados, realize os passos a seguir:
- Execute o comando abaixo na base de dados:
SELECT * FROM R911SRV WHERE NUMSEC <> 0
1.1 Este comando vai retornar todos os códigos que estão em uso. Deve-se localizar o código que se refere ao código do candidato em questão. Ex.:
Para o candidato 703377, é retornado no campo R911SRV.NumSrv o valor 10070337.
Candidato com problema:
Candidato "preso" na tabela R911SRV:
Neste caso, deve-se deletar apenas o registro com problema. Ex.: DELETE FROM R911SRV WHERE NUMSRV = 10070337
Observação: Antes de executar o comando, realize um backup da tabela R911SRV.
2. Caso com a opção acima ainda não resolveu o problema, execute o passo a seguir:
2.1 Exclusão do registro pendente na tabela R126CPE:
DELETE FROM R126CPE WHERE CODRQU = codigo_da_requisição and NUMCAN = numero_candidato
Observação: Antes de executar o comando, realize um backup da tabela R126CPE.