WMS SILT - Integração - Não existe quantidade disponível para o produto
Incidente
No módulo de integração de arquivo, ao tentar importar um arquivo, é apresentada a mensagem:
PRODUTO. CODIGO: XX NAO FOI IMPORTADO ORA-20100: NÃO EXISTE QUANTIDADE DISPONIVEL PARA O PRODUTO ID: XX DA NOTA ID: XX. QUANTIDADE DISPONÍVEL: 0 E QUANTIDADE SOLICITADA: X. LOTE INDUSTRIA/SERIE: XX
Causa
Esta mensagem é apresentada, pois o produto possui controle de informação específica, como lote, data de vencimento, lote indústria entre outros. E o arquivo da importação está com um desses dados divergente com os dados do WMS.
Solução
Para que este incidente não ocorra, existem duas alternativas:
1. Para corrigir os dados no WMS, realize os passos abaixo:
1.1. Acesse o menu Navegação / Movimentação / Gerenciador de Lote;
1.2. Procure pelo lote desejado e utilize os botões do grupo Controle para alterar os dados desejados:
1.3 Após finalizar as alterações, tente realizar a importação novamente.
2. Para corrigir os dados na integração, realize os passos abaixo:
2.1 Se for uma integração REST, arquivo de texto ou banco-a-banco, revise os dados a serem importados. Todos os dados devem bater com os mesmo dados existentes no WMS:
2.2. Acesse o menu Navegação / Consulta / Estoque / Estoque Local por Lote;
2.3. Valide se os dados em tela estão iguais aos dados do arquivo, como:
- Lote ou Lote Indústria;
- Data de Fabricação ou Vencimento;
- Série;
2.4 Corrija as divergências no arquivo e tente realizar a importação novamente.
Observação: Se o arquivo for um XML, tais dados estão contidos na tag <rastro>, onde não recomendamos que tais dados sejam alterados.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.