ERP – Manutenção de Ordens de Produção/Serviço – Problemas para posicionar na tabela de Solicitações de Compra (E405SOL).
Incidente
Ao tentar excluir uma operação externa da Ordem de Produção através da tela NF900MOP_MPMO - Manufatura / Gestão de PCP / Manutenção de Ordens de Produção/Serviço / Alteração / Individual (Manutenção OP/OS), é apresentada a mensagem: Problemas para posicionar na tabela de Solicitações de Compra (E405SOL).
Causa
Essa mensagem ocorre quando, o parâmetro 'Gera solicitação de Serviço na Geração de O.P.s/O.S.s', do cadastro de origem NF083ORI - Cadastros / Produtos e Serviços / Origens / Cadastro (Origem de Produto), estava configurado como 'N-Não' ou 'S-Sim', e depois de a Ordem de produção já ter sido gerada, houve uma nova alteração desse parâmetro para 'N'Não' ou 'S-Sim'.
Observação
Na exclusão da operação o sistema está checando que em determinado momento a O.P. indicou que deveria ter uma solicitação de compras a excluir e não encontra, causando a crítica.
Solução
Para que a mensagem não seja apresentada, realize os passos a seguir:
1. Acesse a tela NF083ORI - Cadastros / Produtos e Serviços / Origens / Cadastro (Origem de Produto);
2. Informe o código da origem que pertence ao produto acabado da Ordem de Produção;
3. Altere o parâmetro 'Gera solicitação de Serviço na Geração de O.P.s/O.S.s', para como estava quando a O.P. foi gerada, ou seja, para a situação original;
4. Realize novamente a manutenção da O.P., conforme necessidade do seu processo.