ERP – Componentes – Não encontrou código do cliente (E120PED), problemas de integridade do sistema
Incidente
No processo de Baixa de Componentes via processo automático, está sendo apresentada a mensagem: Não encontrou código do cliente (E120PED), problemas de integridade do sistema.
Causa
Essa situação ocorre porque, o ERP faz uma checagem no pedido porque dependendo do cliente, pode haver componentes que precisam ser baixados ou não, conforme parâmetro do cadastro do modelo na tela F700CMC - Manufatura / Gestão de Engenharia de Produto/Serviço / Composição Modelo / Composição Produto/Serviço (Modelo (Composição do Produto/Serviço)), Baixa na OP. Por isso, quando há pedido nesse cenário, o sistema verifica quem é o cliente do pedido, e se houver algum problema de integridade é apresentada a mensagem.
Solução
Para análise do assunto, realize os passos a seguir:
1. Gere um log SQLMON do processo automático, e verificar se o ERP está encontrando o código do cliente para o pedido vinculado a OP, que apresentou a mensagem;
2. A partir das informações avaliadas no log do SQLMON, será necessário que o usuário tome decisões para seguir com o assunto:
2.1. Avalie digitar esse pedido novamente com dados compatíveis aos da OP;
2.2. ou então, avalie retirar a informação do pedido na respectiva OP;
Importante
As alternativas citadas acima tem que ser realizadas via banco de dados, avalie primeiramente realizar em base de homologação se houver essa possibilidade, e depois aplicar na produção.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.
Para maiores informações sobre a geração de log SQLMON, verifique o artigo: Tecnologia - SQLMon - Quais são os passos para gerar o Log do SQLMon