ERP - Contrato de Compra - Ao realizar o recebimento de um contrato, é gerada a mensagem Nenhum Contrato encontrado
Incidente
No módulo de Gestão de Recebimento, ao realizar o recebimento de um Contrato de Compra através da Tela F461GNC_SRNF - Suprimentos / Gestão de Recebimento / Notas Fiscais de Entrada / Via Contrato Comercial, esta apresentando a mensagem 'Nenhum Contrato entrado'.
Causa
Essa mensagem é apresentada, pois são observadas algumas informações para que o contrato seja listado na Tela F461GNC_SRNF - Suprimentos / Gestão de Recebimento / Notas Fiscais de Entrada / Via Contrato Comercial.
Solução
Para que esta mensagem não seja apresentada, verifique se o contrato atende os seguintes parâmetros:
1. Situação Contrato (E460CTR.SitCtr) deve estar igual a 'A-Ativo';
2. A quantidade de Parcelas Processadas (E460CTR.ProPar) deve ser menor que Parcelas Previstas (E460CTR.QtdPar);
3. A nota fiscal cujo número está no contrato não pode estar na situação 1-Digitada;
4. A competência atribuída como filtro deve ser maior que a data da última nota faturada;
5. Verifique qual é a data da última nota fiscal gerada a partir do contrato. Isto pode ser verificado na guia Complemento da tela de cadastro de contratos, pois é permitido somente um faturamento por competência. O campo 'Último Processamento' (E460CTR.UltGoc) da aba Complemento do Contrato pode ajudar na verificação de quando que foi realizado o último processamento do contrato, permitindo comparação com a competência que está sendo processada;
6. Verifique se a competência não foi saltada. Isto pode ser verificado na guia Observações da tela de cadastro de contratos. Ao saltar uma competência, é gerada uma observação no contrato;
7. Se houver aprovação multinível para a rotina de contratos, o contrato deve estar aprovado.