ERP – Composição do Produto – Número de nível do componente inválido
Incidente
No processo de Composição do Produto, ao incluir um componente no modelo via telaF700CMC_MECO - Manufatura / Gestão de Engenharia de Produto/Serviço / Composição (Modelo) / Composição Produto/Serviço, é apresentada a mensagem: Número de nível do componente inválido.
Causa
Essa mensagem ocorre porque o parâmetro 'Utilizar Nível Origem', da tela F070EPR - Cadastros / Empresas, está definido como 'S-Sim'.
Nesse caso, ao incluir um componente no modelo é realizado a consistência se o número de nível do componente que será incluído é maior ao número de nível do produto do modelo.
Solução
Para que a mensagem não ocorra, siga os passos abaixo:
-
Acesse a tela F083ORI - Cadastros / Produtos e Serviços / Origens / Cadastro;
-
Verifique no cadastro da origem do Produto Componente e da origem do Produto Produzido (produto do modelo) o valor definido no campo 'Número Nível' (referente ao campo E083ORI.NumOri do banco de dados);
2.1. Se o valor definido no campo 'Número nível' da origem do Produto Componente é igual ou maior que o valor definido no campo 'Número nível' da origem Produto Produzido, a mensagem 'Número de nível do componente inválido' ocorrerá;
2.2. Verifique para que seja adicionado no modelo do Produto Produzido um Produto Componente cuja origem tenha um nível inferior.
Observação
Se o valor definido no campo 'Número nível' da origem do Produto Componente é menor número de nível do Produto Produzido, a mensagem 'Número de nível do componente inválido' não ocorrerá.
Atenção:
Uma vez configurado como 'S-Sim', o parâmetro 'Utiliza Nível Origem,' da tela F070EPR - Cadastros / Empresas, caso você opte por alterar para 'N-Não', haverá impacto em outras áreas do sistema, como por exemplo o módulo de Custos.
Para mais informações sobre o parâmetro 'Utiliza Nível Origem', clique aqui para acessar a documentação da tela.
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.