ERP Senior X – Notas Fiscais de Entrada – Não foi possível definir o fornecedor. Foi localizado mais de um fornecedor para o CNPJ/CPF/NIF XX
Incidente
No módulo Gestão de Recebimento do ERP Senior X, ao tentar receber uma nota, é apresentada inconsistência com a mensagem: Não foi possível definir o fornecedor. Foi localizado mais de um fornecedor para o CNPJ/CPF/NIF XX.
Causa
Esta mensagem é apresentada normalmente quando a nota é de importação e o fornecedor estrangeiro não tem o NIF (tag <idEstrangeiro>) na nota. Para vincular o fornecedor do XML com o cadastro de pessoa, primeiro o sistema olha o código NIF e depois busca pela Razão Social.
Solução
Para que a mensagem não seja apresentada ao efetuar o recebimento de nota, realize os passos a seguir:
1. Acesse no menu em Cadastros / Pessoas / Cadastro;
2. Caso a pessoa ainda não esteja cadastrada, clique em Adicionar / Pessoa jurídica;
2.1. Informe os campos necessários, e no campo Razão social informe exatamente o nome do fornecedor que consta no XML (inclusive com espaços e caracteres especiais);
2.2. Salve o cadastro;
3. Caso já tenha a pessoa cadastrada, selecione o registro e clique em Editar;
3.1. No campo Razão social informe exatamente o nome do fornecedor que consta no XML (inclusive com espaços e caracteres especiais);
3.2. Salve o cadastro;
4. Acesse a nota de recebimento e clique em Reprocessar: