ERP – Cancelamento Necessidades – O item do pedido está atendido (situação 4) e assim não é possível alterar o mesmo
Incidente
No módulo de Manufatura, na tela F813CNE_MPLP - Manufatura / Gestão de PCP / Cancelamento de Produção / Automático Multinível (Cancelamento de Plano de Produção e Compra p/ nec. já explodidas), ao tentar cancelar um item de pedido, é apresentada a mensagem:
O item do pedido está atendido (situação 4) e assim não é possível alterar o mesmo
Causa
Essa mensagem ocorre porque o Item do pedido está com a situação liquidada, ou seja, igual a 4 (E120IPD.SItIpd).
Nesse caso, não é mais possível cancelar necessidades.
Observação
O caminho normal para um pedido no processo produtivo é:
- Gerar o pedido;
- Explodir as Necessidades e gerar a Ordem de Produção;
- Dar entrada no estoque via Ordem de Produção;
- Faturar o pedido para o cliente;
Importante
Então, depois de faturar um pedido, nativamente não é possível realizar ações como cancelar as necessidades.
Essa ação deveria ter sido realizada antes de faturar o pedido.
Observação
Para esse cenário, é necessário que o item do pedido esteja diferente de 4 (liquidado).
Atenção! Antes de realizar qualquer alteração, analise o impacto que poderá ter em outros lançamentos/processos do sistema.